WePay Outage
Incident Report for Neon Fundraise
Resolved
WePay says that everything is resolved. We'll still be monitoring.
More info at https://status.wepay.com/
Posted Mar 15, 2017 - 15:11 PDT
Identified
WePay is experiencing an outage. More details on their status page: https://status.wepay.com/incidents/ddtrcw257xqv
Posted Mar 15, 2017 - 14:27 PDT