Neon One Portal slow loading times

Incident Report for Neon Fundraise

Resolved

This incident has been marked as resolved following extended monitoring of the solution put in place.
Posted Jun 24, 2026 - 07:00 PDT

Update

All systems are currently operating as expected and Admin users should no longer be experiencing delays when logging in. We will continue to monitor the situation.
Posted Jun 23, 2026 - 13:40 PDT

Monitoring

We are experiencing additional issues with Admin users being able to login to the system. Users may experience intermittent delays when attempting to access Neon apps. This does not affect individual Fundraiser access to their pages. The team is actively working on a resolution and will update here with more information as we work to resolve the issue.
Posted Jun 23, 2026 - 13:11 PDT