Hosting provider (AWS) experiencing degradation of services

Incident Report for Neon Fundraise

Resolved

AWS has confirmed that their fix is working as expected. At this point, we have concluded our investigation and have not found any additional services affected within Neon Fundraise. Please reach out to support with any additional questions or concerns.

AWS Statuspage: https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 14:17 PDT

Update

AWS (our hosting provider) experienced a degradation of services last night and continues to experience issues in rectifying services. Overall Fundraise systems are operational as of now. At this point we have not discovered any affected services, but we are continuing to investigate to determine any impact.

Information on the outage from AWS can be found here: https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 09:56 PDT

Monitoring

AWS (our hosting provider) experienced a degradation of services last night and continues to experience issues in rectifying services. Overall Fundraise systems are operational as of now, but we are continuing to investigate to determine any impact.

Information on the outage from AWS can be found here: https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 06:58 PDT