Intermittent charging issues with Neon Pay

Incident Report for Neon Fundraise

Monitoring

All charges have continued to process as expected - we will continue to monitor the situation before marking this as fully resolved.
Posted Mar 20, 2026 - 17:00 PDT

Update

We have isolated the issue and mitigated the affect to Payments. All charges are currently processing as expected and we are continuing to monitor as we work towards full resolution.
Posted Mar 20, 2026 - 15:59 PDT

Investigating

We are currently investigating an issue causing charges to intermittently fail on Neon Pay.
Posted Mar 20, 2026 - 15:15 PDT
This incident affects: Payments (Neon Pay).