USAePay Outage
Incident Report for Neon Fundraise
Resolved
On our end, the USAePay issue looks to be resolved. We're still monitoring it closely. You can find more info at https://status.usaepay.com/.
Posted Mar 21, 2017 - 13:26 PDT
Identified
USAePay is having a network outage. You can see updates at https://status.usaepay.com/
Posted Mar 21, 2017 - 12:06 PDT